ruby 다운로드

ActiveRuby는 레일 및 기타 최고 보석으로 미리 컴파일 된 설치가 쉬운 루비 배포판입니다. 루비를 다운로드하고 개발을 무료로 시작하십시오. 루비 서브버전 및 Git 리포지토리에 대한 자세한 내용은 루비 코어 페이지를 참조하십시오. FreeBSD는 루비를 설치하기 위해 미리 패키지된 방법과 소스 기반 방법을 모두 제공합니다. 미리 빌드된 패키지는 pkg 도구를 통해 설치할 수 있습니다: 자신의 루비를 컴파일할 수 없고 타사 도구를 사용하지 않으려면 시스템의 패키지 관리자를 사용하여 Ruby를 설치할 수 있습니다. 루비 소스는 전 세계 미러 사이트 집합에서 사용할 수 있습니다. 가까운 거울을 사용해 보십시오. FreeBSD에 루비와 주변 생태계에 대한 자세한 내용은 FreeBSD 루비 프로젝트 웹 사이트에서 찾을 수 있습니다. 소스에서 루비를 구축하는 방법에 대한 자세한 내용은 설치 페이지를 참조하십시오. 루비를 컴파일하는 데 문제가 있는 경우 위에서 언급한 타사 도구 중 하나를 사용하는 것이 좋습니다. 그들은 당신을 도울 수 있습니다.

RVM을 사용하면 시스템에 루비의 여러 설치를 설치하고 관리할 수 있습니다. 또한 다른 gemset을 관리할 수도 있습니다. macOS, Linux 또는 기타 UNIX와 같은 운영 체제에서 사용할 수 있습니다. 어떤 버전을 다운로드해야 할지 잘 모르시나요? 권장 사항에 대한 오른쪽 열을 읽어보시기 바랍니다. 소스 기반 메서드를 사용하여 포트 컬렉션을 사용하여 Ruby를 설치할 수 있습니다. 이 기능은 빌드 구성 옵션을 사용자 지정하려는 경우에 유용합니다. 어떤 버전을 설치해야 할지 모르고 루비를 시작하는 경우 Ruby+Devkit 2.6.X(x64) 설치 프로그램을 사용하는 것이 좋습니다. 그것은 호환 보석의 가장 큰 숫자를 제공하고 루비와 함께 MSYS2-Devkit을 설치, 그래서 C 확장 보석을 즉시 컴파일 할 수 있습니다. 32비트(x86) 버전은 사용자 지정 32비트 네이티브 DLL 또는 COM 개체를 사용해야 하는 경우에만 권장됩니다. RubyInstaller는 릴리스 날짜에 최신 GCC로 컴파일됩니다. 설치된 루비는 네이티브 Windows 응용 프로그램이지만 MSYS2의 풍부한 UNIX 도구 집합 및 MINGW 라이브러리의 대규모 저장소와 결합합니다. 주요 패키지 관리자는 최신 릴리스 대신 이전 Ruby 버전을 설치할 수 있습니다.

최신 Ruby 릴리스를 사용하려면 패키지 이름이 버전 번호와 일치하는지 확인합니다. 또는 전용 설치 관리자를 사용합니다. 새 Ruby 버전이 다른 안정 분기의 경우 설치를 위해 새 대상 디렉토리를 사용하십시오. 즉, 이전 RubyInstaller-2.5.x 설치는 동일한 디렉토리에 RubyInstaller-2.6.x를 설치하여 업데이트해서는 안됩니다.